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Introduction 
This Quick Start-up Guide will help you get started with the main features found in 
TimeChainage. If you use the suggested workflow as described below, you will be able to 
produce a basic time chainage project quickly and easily. 

There are many features not described in this guide, or only described briefly. For a more 
comprehensive reference document, please see the User Manual. 

Basic Workflow 
To open the TimeChainage application: 

• Double click on the ‘TimeChg’ executable file to open the application 

• If you have an icon on the desktop, then double click on that to open the 
application 

Setting the Project Details: 

• Click the ‘Project Details’ button on the main form toolbar (or select Data->Project 
from the main menu) to open the Project form 

• Enter a project name, description, planner and start date 

• Enter any project preferences in the ‘Preferences’ section 

• Click OK button to close the Projects form 

Create project calendars: 

• Click the ‘Calendars’ button on the main form toolbar (or Data->Calendars from 
main menu) to open the Calendars form 

• A default 5 day calendar exists (this cannot be changed or deleted) 

• Click the ‘New…’ button to create a new calendar, the Calendar Details form will 
open 

• Give the calendar a name, select the working days and add holidays 

• Click the OK button to close the Calendar Details form 

• Click the OK button to close the Calendar form, or click the ‘New’ button to create 
more calendars 

• Note that the export button in the Calendars window allows you to save your 
calendars for use in other projects. Use the Import button to load ready made 
calendars. 

Create a Work Breakdown Structure (WBS): 

• Click the ‘WBS’ button on the main form toolbar (or Data->WBS from the main 
menu) to open the WBS form 
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• Add new WBS items by pressing the down key on the keyboard when the last item 
is selected in the table, or by pressing the ‘+’ button on the toolbar 

• Enter details in the table or in the details panel at the bottom of the form 

• Minimum details to add are the description and default calendar, but you will also 
want to select line styles, colours and widths. Select your options in the details 
panel or type directly in the table 

• Close the WBS form by clicking the ‘Close Form’ button in the toolbar (the right 
most button with a push button shape) 

• It is worth spending a bit of time creating the WBS as it helps determine the look of 
the chart and the structure for entering planned and actual progress 

Add Planned activities and programme logic: 

• Click the ‘Planned activity details’ button on the main form toolbar (or Data-
>Planned from the main menu) to open the Planned form 

• Click on the first row in the table to create the first activity 

• Use either the table or the details panel to enter the activity details 

• As a minimum, you need to enter start and finish chainages (chainage simply means 
a location), the peak rate and the calendar to produce a time chainage bar. 
TimeChainage will calculate the duration of the task and the start and finish dates. 
As you will have added a default calendar to your WBS definitions, instead of 
selecting a calendar, select the appropriate WBS value and the right calendar will 
be displayed. You can of course override the default calendar for any activity by 
selecting a new one. 

• TimeChainage does not use specific units for distance, you decide what unit of 
measurement you wish to use and enter chainages and rates based on this unit. For 
example, if metres are the units you wish to use, then entering a start chainage of 
0 a finish chainage of 100 and a peak rate of 5 will represent an overall length of 
100m and a peak rate of 5m/day, giving a duration of 20 days.  

• Set the WBS for the task by selecting from the drop down list in the details panel  

• Adding a description is important to keep track of your tasks, this can also be 
displayed on the time chainage chart 

• If there is no start/finish constraint or predecessor logic entered, the task will 
commence on the Project Start Date as set in the Project Form 

• To enter a start or finish constraint, select a constraint type from the drop down 
menu in the details panel and select the required date from the date selection box 

• To enter a predecessor, add the reference ID of the predecessor task in the table 
column ‘Predecessor’. Up to 10 predecessors can be entered for an activity. To 
enter more than one predecessor, use the relationships tab in the details panel at 
the base of the form. See the User Manual for more information on adding 
relationships 
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• To create a bar instead of a line, enter a peak rate as for a line, but also add a 
duration (in days) in the Point Duration field. For example, entering a Point 
Duration of 5 will result in a bar that is 5 days in duration. This represents an 
activity that spends 5 days at any single location 

• You can schedule all tasks by pressing the enter key on the keyboard,by clicking on 
the ‘Schedule’ button on the toolbar or by pressing F9 on the keyboard. By default, 
closing the Planned form by using the ‘Close Form’ button on the toolbar also 
schedules the programme 

• Enter additional tasks by pressing the down arrow key on the keyboard (when the 
last task is selected), or by clicking the ‘+’ button on the toolbar 

• Move tasks up or down by using the up/down arrow keys on the toolbar 

• To sort the tasks, click on the header of the column you want sorting. Multiple 
clicks on the header will swap between sort ascending and sort descending. Always 
schedule the project prior to moving or sorting tasks 

• By default, all tasks are shown in the Planned Form table. You can filter by a 
specific WBS, WBS Code or Activity Code value by selecting from the drop down 
selection boxes on the toolbar 

• There are a lot of columns in the table, some of which you may wish to hide to 
declutter the form. To do this, simply click on the appropriate Hide buttons on the 
toolbar. By hovering your cursor over a button, a description of what the button 
does will appear. 

• To close the Planned Form, click the ‘Close form’ button on the toolbar (the button 
with a green button shape) 

Format the chart layout: 

• From the main menu select Format->Chart Setup and the Chart Setup dialog will 
open 

• There are a number of tabs on the dialog but the main ones to start with are the 
‘Axis’ and ‘Grids’ tabs 

• The ‘Axis’ tab allows you to format the axis markers and labels on the chart. You 
can show axis markers for both time and chainage on all four sides of the chart 

• The ‘Grids’ tab allow you to format the chart grids. You can have major and minor 
grids for both chainage and time 

• Many other formatting options are available, explore them for yourself or see the 
User Manual for more information on formatting your chart 

• Click ‘OK’ to close the Chart Setup dialog 

• On the Main Form, you can choose the ranges of chainage and time shown on the 
chart. By default the charts shows the entire project, but you may wish to show 
some extra space around the bars or else zoom in to a small portion of the project. 
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To select a specific chart range, uncheck the ‘auto range’ checkbox on the toolbar 
and enter values for chainage and time in the appropriate boxes on the toolbar  

Setting print options: 

• From the main menu, select File->Print Preview 

• Click the ‘Page Setup’ button to open the Page Setup dialog 

• Click on ‘Printer Setup’ to designate a printer and paper size 

• In the Page Setup dialog, select page orientation 

• Click ‘OK’ to close the Page Setup dialog 

• Click the ‘Headers’ button to open the Headers dialog 

• Decide which Headers you wish to have on the chart, the options are a revision 
box, a title box, a logo, a legend box and a schematic 

• For each Header, select the tab and complete the details. Check the ‘Show’ box for 
each header you want to show 

• To show a logo, the picture must be in JPEG or Windows Bitmap format 

• For a Schematic above the chart, you can either create one in TimeChainage using 
the built-in schematic creation tool or you can import an image in JPEG or 
Windows Bitmap format. See the User Manual for more details of how to create a 
schematic using the built-in tool 

• Print options are saved with Layouts (see below)  

Once you have formatted a Layout, you can save it. Multiple Layouts can be saved for a 
project, showing different views. To save a new Layout: 

• From the main menu select View->Layout to open the ‘Layouts’ dialog 

• Click on New to open the ‘Layout Details’ dialog 

• Give the Layout a name and click the ‘OK’ button 

• Click ‘Open Layout’ to close the ‘layouts’ dialog and open the layout 

To save changes to an existing layout: 

• Open the layout you wish to modify 

• Make your layout changes 

• Save the layout by clicking on the ‘Save Layout’ button on the main form toolbar 

To open a layout: 

• From the main menu select View->Layout to open the ‘Layouts’ dialog 
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• Select the layout to open from the drop down list 

• Click ‘Open Layout’ to close the ‘layouts’ dialog and open the layout 

Save the Project file: 

• From the main menu, select File->Save As to open the Save As dialog 

• Give the project file a name and save it in a suitable location. TimeChainage v8.x 
project files have the extension “.tc8” 

Printing 
To print your time chainage chart: 

• From the main menu, select File->Print Preview 

• Click the Page Setup button to open the Page Setup dialog 

• Click on Printer Setup to designate a printer and paper size 

• Click ‘OK’ to close the Page Setup dialog 

• If you are happy with the print preview, then click ‘Print…’ to open the Print 
dialog, then click ‘OK’ to print the chart 

• Tip – Time chainage charts often look better when printed to A2 or larger, 
especially for large and complex projects. However if you do not have a large size 
plotter or simply want a smaller print, the following method works very well: 

o Save your chart as a PDF file – you need a PDF writer such as Adobe Acrobat 
or CutePDF Writer to do this. From the Printer dialog, select your PDF writer 
and print size (say A2) and click ‘OK’ to “print” the chart.  

o A ‘Save As’ dialog will open. Select a name and location to save the PDF 

o Once saved, open the PDF file (you will need a PDF reader for this) 

o Print the chart to A4 or A3 size as desired 

Adding Progress 
You can add actual progress in TimeChainage and compare it with your plan. This is a very 
brief guide to adding progress, see the User Manual for more details. To add actual 
progress: 

• From the main form, click the ‘Actual activity details’ button on the toolbar (or 
select Data->Actuals from the main menu) to open the Actual Progress form 

• Add and delete activities in a similar way as for the Planned Form. An activity is 
simply a section of progress related to a WBS value. You can add as many activities 
as needed to show progress to the level of detail required. 

• For each activity, select the WBS and add start and finish chainages and start & 
finish dates. Any period of time from 1 day upwards can be entered 
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• Enter a description if required. The description can be shown on the chart. 

• Close the Actual Progress form by clicking the ‘Close Form’ button in the toolbar 
(the right most button with a green circle) 

• Ensure that the ‘Actual’ checkbox is checked on the main form toolbar to show 
actual progress 

• Shapes can be shown as well as lines – see the User Manual for details. 

Additional Features 
TimeChainage has many features not described above, see the User Manual for details. 
Additional features include: 

• Allocate activity codes to planned and actual tasks to help with the planning 
process and to display different kinds of information about the project. You can 
format activity lines by Activity Code instead of by WBS and this gives you a wide 
range of charting options. 

• Create WBS Code values to further organise your project 

• Create learning curves based on parameters you specify 

• Filters – create clearer layouts by only showing specific information 

• Line detail – show or ignore non-work time 

• Global and local chainage datums – allows flexibility in chart layouts and simplifies 
progress reporting 

• Add annotations, holidays, backgrounds, data date and logic links to your charts 

• Lines and shapes can be formatted with your choice of colours, line thickness, 
hatch pattern and line styles. Formatting can be set for WBS and Activity Code 
values and for any layout, you select which formatting set to show. 

• Add date milestones and chainage milestones to your charts 

• Create and save Baselines to compare with current project status 

• Complex schematics can be created using the built-in schematic tool, or project 
images such as CAD drawings, photos or other graphics can be imported to show 
across the top of the chart 

• Analyse progress with the built-in Reports 

• Import data from and export data to Microsoft Excel via the Windows Clipboard  

• Use existing Primavera P6 (or other planning applications) to quickly generate time 
chainage charts
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